栏目导航: 首页 > 操作系统 > 其它系统 > 内容

RouterOS 设置VPN自动拨号访问国外网站

www.hx99.net    时间: 2015-02-03    阅读: 次     整理: 华西安全网

 说明:

RouterOS版本:RouterOS 5.25

网卡1(ether1):接外网

IP:192.168.21.100

子网掩码:255.255.255.0

网关:192.168.21.2

DNS:

8.8.8.8

8.8.4.4

网卡2(ether2):接内网

IP:192.168.237.100

子网掩码:255.255.255.0

VPN服务器账号密码:

VPN服务器:10.0.0.100

账号:pptp

密码:123456

实现目的:

通过在RouterOS中设置VPN自动拨号,实现访问国内网站走原来的网络,访问国外网站走VPN线路。

具体操作:

一、RouterOS网络配置

RouterOS路由器管理工具winbox下载地址:http://download2.mikrotik.com/winbox.exe

RouterOS 5.16软路由安装图解教程:http://www.osyunwei.com/archives/4037.html

以下操作在登录RouterOS控制台后进行

1、设置RouterOS登录密码

备注:默认安装之后,登录账户:admin密码为空

下面设置admin的登录密码为:123456

password

old password:

new password:123456 #输入密码

retype new password:123456 #再次输入密码

密码设置完成

2、配置网卡IP地址

interface print #显示可用的网卡信息

会出现ether1 ether2等网卡信息

这里ether1代表网卡1,我们用来连接外网

ether2代表网卡2,用来连接内网

ip address #设置网卡接口IP地址

add address=192.168.21.100/24 interface=ether1 #设置外网地址

add address=192.168.237.100/24 interface=ether2 #设置内网地址

/ip address print #查看接口地址

3、使用winbox登录RouterOS

设置局域网客户机

IP:192.168.237.254(最后一位:1-254,除过100都可以)

子网掩码:255.255.255.0

网关:192.168.237.100

DNS不设置

如下图所示

设置完成之后,打开winbox

Connetct To(连接到):192.168.237.100

Login(登录名):admin

Password(密码):123456

勾选Keep Password(保存密码)

勾选Secure Mode(安全模式)

Load Previous Session(读取以前的会话):由于我们是第一次登录,所以不勾选

Note(注释):可以默认,也可以自己填写

设置好之后,点Connect(连接)

进入RouterOS控制界面

以下操作在winbox中进行

4、修改网卡接口名字

Interfaces

双击打开ether1-General

Name:WAN

点Comment(备注)

外网

OK

Apply-OK

同样的方法修改ether2为LAN,备注为内网

5、设置外网网关(设置默认路由)

IP-Routes

点左上角的+号

Gateway:192.168.21.2

点Comment

外网网关(默认路由)

OK

其他的默认即可

Apply-OK

6、设置NAT网络地址转换,映射外网,把所有内网的访问请求都映射到外网192.168.21.100上面

即所有局域网内的客户机是通过RouterOS路由器的外网IP:192.168.21.100来上网的

IP-Firewall-NAT

点左上角的+号,切换到Action

Action:masquerade

点Comment

NAT网络地址转换

最后,Aply-OK

7、设置DNS服务器

IP-DNS

Services:

8.8.8.8

8.8.4.4

Apply-OK

8、设置DHCP服务器

IP-DHCP Server

切换到DHCP

点DHCP Setup

DHCP Server Interface:LAN

Next

DHCP Address Space:192.168.237.0/24

Next

Gateway for DHCP Network:192.168.237.100

Next

DHCP可分配的IP地址如下

192.168.237.1-192.168.237.99

192.168.237.101-192.168.237.254

默认Next

DNS Servers:8.8.8.8

Next

DHCP租约时间,默认即可

Next

点OK设置完成

测试:

局域网内客户机IP地址设置为自动获得

打开网页,能够上网,配置成功

二、VPN拨号设置

Interface

点+号选择PPTP Client

切换到Dial Out

Connect To:10.0.0.100

User:pptp

Password:123456

Apply

OK

切换到Traffic

能看到有流量通过,说明已经连上VPN服务器

三、在RouterOS中标记除了中国段IP之外的其他所有IP地址

1、导入中国段IP地址

中国段IP地址下载:http://autorosvpn.googlecode.com/files/address-list.rsc

打开Files

把address-list.rsc文件从电脑拖动进来

打开New Terminal

输入:import file=address-list.rsc

IP-Firewall-Address Lists

可以看到刚刚导入进来的IP地址

2、标记IP地址

IP-Firewall-Mangle

General

Chain:prerouting

Dst. Address:!192.168.237.0/24

In.Interface:LAN

Advanced

Dst. Address List:!novpn

Extra

Dst. Address Type

Address Type:local

勾选:Invert

Action

Action:mark routing

New Routing Mark:vpn

Apply

OK

3、设置VPN线路路由

IP-Routes

Dst. Address:0.0.0.0/0

Gateway:pptp-out1

Distance:1

Routing Mark:vpn

Apply

OK

设置完成之后,访问国内网站,走的是原来线路,访问国外网站走的是VPN线路

打开下面这2个网站测试

http://www.ip138.com/

http://www.whatismyip.com.tw/

至此,RouterOS 设置VPN自动拨号访问国外网站教程完成。

本文来源:华西安全网[http://www.hx99.net]
发表评论】【告诉QQ好友】【错误报告】【加入收藏】【关闭